...
In this file we added seperated name space called isolated in which we put p4p2 interface. In order to have any action with that interface it is necessary to type ip netns exec isolated before any known command. For example, to see configuration on that interface we need to type the following:
...
Device | IP Address | Interface | Purpose |
---|---|---|---|
HCoS#1 | 10.1.1.10 | iDrac | web access for management |
10.1.1.21 | em1 | ssh access for configuration | |
192.168.0.1 | p3p2 | HCoS#1-A iPerf client | |
192.168.1.1 | p3p1 | HCoS#1-C iPerf client | |
HCoS#2 | 10.1.1.11 | iDrac | web access for management |
10.1.1.22 | em1 | ssh access for configuration | |
192.168.2.1 | p4p2 | HCoS#2-D iPerf client | |
192.168.0.2 | p4p1.10 | HCoS#2-B iPerf server for point-to-point with HCoS#1-A iPerf client | |
192.168.1.2 | p4p1.20 | HCoS#2-B iPerf server for point-to-point with HCoS#1-C iPerf client | |
192.168.2.2 | p4p1.30 | HCoS#2-B iPerf server for point-to-point with HCoS#2-D iPerf client | |
MX204#1 | 10.1.0.67 | fxp0 | ssh access for configuration |
MX204#2 | 10.1.0.131 | fxp0 | ssh access for configuration |
Configuration on MX204 routers
Code Block | ||
---|---|---|
| ||
system {
host-name Lab-MX204-1;
root-authentication {
encrypted-password "$6$VacgKGnC$4BEpkBv2K/BzzzGT8x7zdssG5WWdnAKwZI730c0NMfMNGWJB75rdQzOKgLheQdCKWk.oh4Mq2iwd.7Ha8.TZX/"; ## SECRET-DATA
}
login {
user admin {
uid 2000;
class super-user;
authentication {
encrypted-password "$6$ANEaOs6/$fEe9dWgcggZKPWrAbsBgfb.bVXmR90f5K8/yCRP0U02jGXyFViuv1JhqdNcfKouKjnIxItqTYOffnZsQ/0OIb1"; ## SECRET-DATA
}
}
}
services {
ssh {
root-login allow;
max-sessions-per-connection 32;
}
telnet;
netconf {
ssh;
}
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
chassis {
fpc 0 {
pic 0 {
port 0 {
speed 100g;
}
port 1 {
speed 100g;
}
port 2 {
speed 40g;
}
port 3 {
speed 10g;
}
}
pic 1 {
port 0 {
speed 10g;
}
port 1 {
speed 10g;
}
port 2 {
speed 10g;
}
port 3 {
speed 10g;
}
port 4 {
speed 10g;
}
port 5 {
speed 10g;
}
port 6 {
speed 10g;
}
port 7 {
speed 10g;
}
}
}
}
interfaces {
et-0/0/0 {
description to_MX204-2_et-0/0/0;
flexible-vlan-tagging;
mtu 9000;
encapsulation flexible-ethernet-services;
unit 10 {
encapsulation vlan-ccc;
vlan-id 10;
input-vlan-map pop;
output-vlan-map push;
family ccc;
}
unit 20 {
encapsulation vlan-ccc;
vlan-id 20;
input-vlan-map pop;
output-vlan-map push;
family ccc;
}
unit 30 {
encapsulation vlan-ccc;
vlan-id 30;
input-vlan-map pop;
output-vlan-map push;
family ccc;
}
}
xe-0/0/3:0 {
description to_HQoS1_p3p2;
mtu 9000;
encapsulation ethernet-ccc;
unit 0 {
filter {
input ccs-mf-classifier;
}
family ccc;
}
}
xe-0/0/3:1 {
description to_HQoS2_p4p2;
mtu 9000;
encapsulation ethernet-ccc;
unit 0 {
filter {
input ccs-mf-classifier;
}
family ccc;
}
}
xe-0/1/0 {
description to_alpha-compute0_p2p2;
mtu 9000;
unit 0;
}
xe-0/1/1 {
description to_alpha-compute1_em4_via_lab4-MX80_ge-1/3/8_xe-0/0/2;
mtu 9000;
unit 0;
}
xe-0/1/2 {
description to_alpha-bms2_p4p1;
mtu 9000;
unit 0;
}
xe-0/1/3 {
description to_alpha-bms3_p4p1;
mtu 9000;
unit 0;
}
xe-0/1/4 {
description to_HQoS1_p3p1;
mtu 9000;
encapsulation ethernet-ccc;
unit 0 {
filter {
input ccs-best-effort;
}
family ccc;
}
}
xe-0/1/5 {
description to_Corsa1_3;
mtu 9000;
unit 0;
}
fxp0 {
unit 0 {
family inet {
address 10.1.0.67/26;
}
}
}
lo0 {
unit 0 {
family inet {
address 10.0.16.31/32;
}
}
}
}
routing-options {
static {
route 0.0.0.0/0 {
next-hop 10.1.0.65;
retain;
no-readvertise;
}
}
autonomous-system 65250;
}
protocols {
mpls {
interface all;
}
connections {
interface-switch ccc_AB {
interface xe-0/0/3:0.0;
interface et-0/0/0.10;
}
interface-switch ccc_CB {
interface xe-0/1/4.0;
interface et-0/0/0.20;
}
interface-switch ccc_DB {
interface xe-0/0/3:1.0;
interface et-0/0/0.30;
}
}
lldp {
interface all;
}
}
class-of-service {
forwarding-classes {
class ccs-best-effort queue-num 0;
class ccs-premium queue-num 7;
}
}
firewall {
family any {
filter ccs-mf-classifier {
term premium-data {
then {
policer ccs-policer;
forwarding-class ccs-premium;
}
}
}
filter ccs-best-effort {
term best-effort-data {
then forwarding-class ccs-best-effort;
}
}
}
policer ccs-policer {
if-exceeding {
bandwidth-limit 1g;
burst-size-limit 625k;
}
then discard;
}
} |
iPerf tool for HCoS testing
...